Tools.triathlon.org down
Incident Report for World Triathlon
Resolved
This incident has been resolved.
Posted Sep 24, 2021 - 14:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 24, 2021 - 14:12 UTC
Update
We are still investigating the issue. Next update at 2pm GMT.
Posted Sep 24, 2021 - 12:55 UTC
Investigating
We are currently investigating this issue.
Posted Sep 24, 2021 - 12:30 UTC
This incident affected: Triathlon.org (Tools.triathlon.org).