Athlete search may be degraded
Incident Report for World Triathlon
Resolved
This incident has been resolved.
Posted Jun 10, 2021 - 19:51 UTC
Update
We are rebuilding indexes. Search will be back soon.
Posted Jun 10, 2021 - 19:31 UTC
Identified
We are currently fixing this issue.
Posted Jun 10, 2021 - 19:08 UTC
Investigating
We are currently fixing this issue
Posted Jun 10, 2021 - 19:07 UTC
This incident affected: Triathlon.org (Triathlon.org and Associated Websites).